Oui, j'ai finit mon coup de gueule sur la freebox :P Je passe à l'hébergement maintenant :D

Avec un abonnement chez Free, on a le droit à un espace web gratuit d'1 Go, avec PHP et une base de donnée MySQL ou PostgreSQL. Cool :)

Par contre, lors de l'installation de Piwik (un google analytics open source), j'ai eu droit à un joli message précisant qu'il faut au minimum PHP 5.1.3...
La version installée sur ce serveur est 5.1.3RC4-dev, une RC pour un serveur de prod ?!
Pas grave, je bidouille les sources de Piwik pour que ça passe... Et là, nouveau message d'erreur, il faut l'extension PDO.
Je balance un phpinfo() dans un script, et tombe sur ce résultat : PDO est installé, mais ne supporte que les base SQLite !
Génial... quand on a une base MySQL ou PostgreSQL... :/

Merci la logique free :P